
BODC Underway Explorer

When the program starts up, the Underway Explorer control window is
opened. Initially, the Select, View and Window menus and most of the control
buttons are inactive. These are activated by opening the File menu and
choosing a project from the Select Project sub-menu. If the software has just
been installed then this will offer a choice of one. However, by making
appropriate changes to the Windows95 Registry, the software may be used in
conjunction with other BODC CD-ROM products that include underway data.

Once the project has been selected, the control window appears thus:

This presents five pull-down menus, plus two types of button. The menus are
accessible through mouse clicks or by pressing Alt and the appropriate 'hot
key' simultaneously. Hot key characters are underlined in the menus.

The group of five smaller buttons are termed universal control buttons. These
invoke a standard set of control options. However, their detailed function is
context sensitive, depending upon which view window has focus. They are
therefore documented in the view window descriptions. These options may
also be invoked by the File pull-down menu.

The three larger buttons open the three display windows which are (from left
to right) the Plot View, the Data View and the Map Area View. These windows
may also be opened using the View pull-down menu and selecting the Plot,
Data and Map options as appropriate. The view focus may be controlled
through the Window pull-down menu or simply by clicking on the window
control bar.

The view windows may be opened immediately, but will only display the
default data selection. However, it is assumed that users will want to control
the data displayed, which is defined using the Selection Dialog. This is
invoked by choosing the Select pull-down menu.



The Selection Dialog

Click on the window within the dialog to find out what it does



The Cruise Window

This window is used to specify the cruise from which data are displayed. If
the number of cruises is too great to be displayed at once, then the list may
be moved up and down using the scroll bar at the right hand side of the
window.

The cruise is selected by simply clicking on it. Note that there will be a delay
of a second or two after a cruise has been selected because the program
needs to access the data file on the CD-ROM to obtain the dates covered by
the cruise.



The Parameters Available Window

This window displays the parameters that are available in the underway file of
the cruise currently selected. If the number of parameters is too great to be
displayed at once, then the list may be moved up and down using the scroll
bar at the right hand side of the window.

Parameters may be dragged from here and dropped into the Parameters
Included window as required.



The Parameters Included Window

The Underway Explorer is capable of displaying up to six parameters at a
time, whereas an underway file may contain some twenty or thirty
parameters. The Parameters Included window specifies which of the
parameters are to be included in the display windows.

Parameters are inserted into the Parameters Included window from the
Parameters Available window by dragging and dropping. Parameters are
deselected using the right mouse button. It is not necessary to specify all six
parameters. It is perfectly permissible to set any of the list items to 'Unused'
by right clicking.

The number of parameters specified and the order of them in the list has
some relevance. The Plot View window displays up to three stacked time
series plots with two parameters displayed per plot. Parameters one and two
are displayed on the top plot, three and four on the middle and five and six on
the bottom. The parameters are displayed in the Data View window from left
to right in the order one to six.

Where the parameters are placed in the display windows may not seem to be
particularly important. However, the effects are more dramatic when less than
six parameters are selected. If both of the parameter slots for a plot are set to
'Unused' then the display of that plot is suppressed. Consequently, it is
possible to fill the Plot Display window with just one or two plots instead of
three.

It is also possible to produce three plots with just one parameter each by
filling slots one, three and five. These plots have the axis labels on the left
hand side. If slots two, four and six are filled then the axis labels are on the
right hand side. Note that whilst embedding used and unused slots provides
a mechanism for controlling the appearance of the Plot View window, it has
the side effect of embedding 'Unused' columns in the Data View window.

The order of parameters in the list may be modified by dragging and dropping
the slot numbers within the window.



The Dates Window

This window, together with the start and end time windows, allows a subset of
the underway data file to be selected. Initially, the whole cruise is selected.
To select data from a single day, simply click the date. To select a range of
days, either drag the cursor over the required dates or click the first date in
the range and then shift click the last date.

Initially, the selection is from 00:00 on the first day selected to 23:59:59 on
the last day selected (annotated as 24:00 for convenience). This may be
further refined using the start and end time windows.



The Start and End Time Windows

By default the data selected extend from the start of the first day selected to
the end of the last day selected. To refine this, enter the desired start and
end times into the start and end time windows. Simply click on the window
and use the keyboard to enter the desired time.



The Flags Window

Every data value in the underway data files include flags that have been
applied either by the originating logging systems or during BODC quality
control. The flags used are:

G Good data
N Null data  (usually accompanied by a value of 0)
S Suspect data
U Data outside calibration range
I Interpolated data
B Bad data

Data flagged 'U' are the result of calibration extrapolation and therefore may
be less reliable than data within the calibration range. However, the data will
have been reviewed during quality control inspection and if a serious problem
has been identified then the flags will have been upgraded to 'S'.

Data are only flagged 'I' if the data were identified as interpolated by the
originator, or if they have been interpolated by BODC processing software.
This latter possibility is restricted to navigation channels.

In practice, 'B' flags are very rarely used. They are carried across from the
UK vessel system where they identify known hardware failures.

Data carrying the flags checked in the Flags Window will be included in the
plots displayed in the Plot View window. The plotting of data points with other
flags is suppressed. The flags may also be optionally used to restrict the data
included in the Data View window.

Flags are checked and unchecked in the Flags Window by clicking on the
check boxes.



The Plot View

The Plot View window opens up looking something like this:

This is purely a data display window and as such, it doesn't do very much.
The only thing it can do is to scroll the subset of the time series displayed left
(forwards in time) or right (backwards in time) by a day or an hour by clicking
on the window with the left or right mouse button as appropriate.

However, observant users will have noticed that whenever the Plot View
window has the focus, the Control Window changes its appearance as shown
below with a second crop of window-specific control buttons to the right of the
window selection buttons.

Click on any of the universal or window-specific control buttons
to see what they do.



Selecting the View pull-down menu gives access to the following options in
the Plot section:

Zoom In
Zoom Out
Scroll Width
Colours
Scale

These provide the same functionality as the window-specific control buttons.

Selecting the File pull-down menu gives access to the following options in
addition to the usual 'Close' and 'Exit':

Save As
Copy to Clipboard
Page Setup
Print
Print Setup

These provide the same functionality as the universal control buttons.



Zoom In and Zoom Out
Plot View

When the Zoom In option is selected, the appearance of the Plot View
window changes thus:

The points to note are the two vertical grey bars over the Y-axes and the
'Redraw' button. These bars may be dragged into the body of the plot. Once
the feature of interest has been bounded by the bars, press the 'Redraw'
button and the selected data will be expanded to fill the full plot.

Obviously, the Zoom Out option is only available once the Zoom In option
has been invoked. Selecting Zoom Out returns the plot to magnification in
force before the Zoom In option was selected. Note that it is possible to Zoom
In repeatedly and the Zoom Out option returns to the magnification set by the
previous zoom.



Scroll Width
Plot View

The data in the Plot View window may be scrolled left or right using the left
and right mouse buttons. This scrolling, by default, is a day at a time.
However, this may be reduced to an hour at a time and subsequently
returned to a day at a time using the Scroll Width option.



Colours
Plot View

The Colours option allows the colour of each individual element of the Plot
View window to be changed by the user. Control is provided through the
Colour Dialog.

The plot elements, including the
background, are shown in their current
colours. To change the colour of an
element, double click on it and the
standard Windows Color Dialog is
opened up allowing the colour for that
element to be chosen.

Once all the elements have been set up as required, then selecting OK will
cause the Plot View window to be redrawn in its new colour scheme.

The 'B&W' button imposes a colour scheme of all elements in black on a
white background. Thus a format suitable for printing on a black and white
printer may be obtained through a single button push. When the button has
been pressed, it transforms into a 'Colour' button that will restore the previous
colour scheme at a stroke.

Note that changes to the colour scheme are stored in the program's ini file
and will therefore become the defaults for subsequent program runs.



Scale
Plot View

The default Y-axis scales are determined by the program for the data.
However, this may not always be what is required. For example most users
will not want salinities logged on the passage from harbour to determine the
scale used for oceanic salinities.

The scales are redefined by the Scale Dialog.

The axis minimum and maximum values are simply typed into the appropriate
boxes. Clicking the 'Default' check boxes restores the program's preferred
values. Once everything is as required, clicking the 'OK' button implements
the changes.



Save As
Plot and Map Views

Choosing the 'Save As' option invokes the standard Windows dialog box. The
contents of the Plot View window or Map View window (whichever has the
focus) are saved in Windows bitmap format, sometimes known as 'bmp'
format.



Copy to Clipboard
Plot and Map Views

This option causes the contents of the Plot View window or Map View window
(whichever has the focus) to be copied to the Windows Clipboard in Windows
bitmap format.



Page Setup
All Views

The Page Setup option invokes the Page Setup dialog that allows the left,
right, top and bottom margins for printed output to be redefined. By default,
these are set at 2.54 cm (1 inch).



Print
All Views

The Print option opens up the standard Windows Print dialog that offers
printer selection, Print Setup and number of copies options prior to
submission of the View contents to the printer.



Print Setup
All Views

The Print Setup opens up the standard Windows Print Setup dialog. The
options available depend upon the printer currently selected. This option may
also be invoked from the Print dialog.



The Data View

The Data View presents the actual numerical data in a grid format that will be
familiar to any spreadsheet user thus:

Whenever the Data View window has the focus, the Control Window changes
its appearance as shown below with a second crop of window-specific control
buttons to the right of the window selection buttons.

Click on any of the universal or window-specific control buttons
to see what they do.

Selecting the View pull-down menu gives access to the following options in
the Data section:

Use Flags
Setup

Selecting the Setup option provides the following options from a sub-menu:

Horizontal Lines
Vertical Lines
Font



The following options are available from the File pull-down menu in addition
to Open Project, Close and Exit.

Save As
Copy to Clipboard
Page Setup
Print
Print Setup

These options provide the same capability as the universal control buttons.



Use Flags
Data View

This option determines how the program handles the quality control flags that
are assigned to each data value. If the option is active then the data
displayed in the Data View are restricted to those with their quality control
flags in the list specified in the Select dialog. If the option is inactive, all data
from the data file are included in the Data View window. Naturally, the flags
are included in the data listing.

The Use Flags option is indicated as active by a check mark next to it in the
pull-down menu. In addition, the icon on the Use Flags button changes from
a flag with no wind to a flag flying in the wind,



Horizontal and Vertical Lines
Data View

These are the background grid lines present in the Data View window. They
are simply toggled on and off using either the buttons or by checking and
unchecking the pull-down menu options.



Font
Data View

Choosing the Font option or pressing the 'F' button opens up a Windows
standard Font dialog. This allows the font type, size, colour etc. to be
selected. Changes affect all the data displayed in the Data View window.



Save As
Data View

Choosing the 'Save As' option invokes the standard Windows dialog box. The
contents of the 'Plot View' window are saved in Windows Comma Separated
Variable format, sometimes known as 'CSV' format.



Copy to Clipboard
Data View

Invoking the Copy to Clipboard option when the Data View window has the
focus opens up the Copy to Clipboard dialog thus:

This allows control through the
check boxes of whether the column
headings are copied, whether fields
are tab or space delimited and
whether the whole Data View
contents are copied. If the Select All
option isn't checked only data from
the Data View window that have
been highlighted by dragging the
mouse cursor over them will be
copied. Once the check boxes are
set up, the data are copied by
pressing the copy button.

Note that this option has the potential for placing huge amounts of data onto
the Clipboard. If the program runs out of resources, it will copy as much as it
can and then issue a warning message. If this occurs, the data must be
transferred to other applications by saving to a file and then loading the file
into the desired application.



The Map Area View

The Map Area View provides spatial context information on the data
displayed in the other two views. It presents a map with GEBCO bathymetry
overlain by the cruise track thus:

It can be seen that part of the cruise track is in green whilst a small section is
in red. The red section shows the track covered by the ship whilst collecting
the currently selected data.

When the Map Area view has focus, the Control Window changes its
appearance as shown below with a second crop of window-specific control
buttons to the right of the window selection buttons.

Click on any of the universal or window-specific control buttons
to see what they do.



Selecting the View pull-down menu gives access to the following options in
the Map section:

Bathymetry
Coastline
Background
Graticule
Cruisetrack
Cursor Position

The following options are available in the File pull-down menu in addition to
Open Project, Close and Exit:

Save As
Copy to Clipboard
Page Setup
Print
Print Setup

These provide the same functionality as the universal control buttons.



Bathymetry
Map View

The bathymetry option allows the bathymetric contours included in the base
map to be specified. By default,  contours are selected at 100 m intervals
from 200 m to 1000 m and then at 1000 m intervals.

Invoking the Bathymetry option opens the Bathymetry dialog. The available
contours are listed and may be selected by clicking on them. Normal
Windows conventions are adopted for the selection of more than one contour:
i.e. the Ctrl key must be held down when clicking on the second and
subsequent selections. Holding down the Shift key when clicking causes a
range to be selected.



Coastline
Map View

Invoking the Coastline option or pressing the 'C' button allows the colour of
the coastline to be changed. The standard Windows Color dialog is opened
from which the desired colour may be selected by clicking.

Note that the coastline may be suppressed if desired by simply setting its
colour to the background colour.



Background
Map View

Invoking the Background option or pressing the 'B' button allows the colour of
the map background to be changed. The standard Windows Color dialog is
opened from which the desired colour may be selected by clicking.



Graticule
Map View

The Graticule option controls the appearance of the grid overlying the base
map. Invoking it opens up a sub-menu containing the following options:

Display
Colour
Style
Format

The first two of these may also be invoked through the GRID ON/GRID OFF
and adjacent colour buttons.

When the Display option is checked or the button is pressed in with the GRID
ON caption, the graticule is present. Otherwise it is suppressed.

Invoking the Colour option or pressing the button with the three crayons logo
allows the colour of the grid to be changed. The standard Windows Color
dialog is opened from which the desired colour may be selected by clicking.

Choosing the Style option opens a dialog that offers a range of line styles
with different mark/space ratios which may be used for the grid lines.

The Format option gives a choice over whether the grid is labelled in decimal
degrees or in degrees, minutes and (for limited area plots only) seconds.



Cruisetrack
Map View

The Cruisetrack option provides control over the appearance of the cruise
track plotted on the map. Invoking it opens a sub-menu offering the following.

Selected Colour
Unselected Colour
Display

The Display option may also be invoked by the 'T' button.

Invoking the Selected Colour option allows the colour of the cruise track with
selected data to be changed. The standard Windows Color dialog is opened
from which the desired colour may be selected by clicking.

Invoking the Unselected Colour option allows the colour of the cruise track
with no data selected to be changed. The standard Windows Color dialog is
opened from which the desired colour may be selected by clicking.

When the Display option is checked, the cruise track is displayed. Otherwise
it is suppressed.



Cursor Position
Map View

The Cursor Position option controls the appearance of a digital readout of the
mouse cursor position when it is within the active area of the Map View
window. Invoking it opens a sub-menu offering the following options.

Display
Colour
Overlay
Background
Format

The Display and Format options are also controlled by the mouse icon and
DMS/DD buttons respectively. Note that DMS stands for degrees, minutes
and seconds and DD stands for decimal degrees.

The Display option simply controls whether or not the digital readout is
displayed.

The Colour option allows the colour of the display digits to be changed. The
standard Windows Color dialog is opened from which the desired colour may
be selected by clicking.

The Overlay option controls how conspicuous the cursor position display is.
When the option is checked, the cursor position display background is
transparent. Otherwise, it is solid.

The Background option allows the colour of the display background to be
changed. The standard Windows Color dialog is opened from which the
desired colour may be selected by clicking.

The Format option controls whether the cursor position is displayed in
degrees, minutes and seconds or decimal degrees.



Editing the Windows 95 Registry

Introduction

Most Windows 95 users, the author included, regard the Windows 95
Registry Editor program, Regedit, as a tool of last resort grasped in
desperation when the operating system has totally fallen apart. Further,
daring to use Regedit is considered, with some justification, to be a foolproof
way of wrecking a perfectly healthy Windows 95 installation.

However, Regedit may be used safely to view the contents of the Registry
and providing great care is taken to ensure that it is backed up and there is
adequate 'first aid' available to restore a damaged Registry it may be used to
modify the Registry. However, there are very few circumstances where users
would wish to do more than inspect what is there. These are documented
below.

The BODC Registry entries may be found under HKEY_CURRENT_USER,
then Software and finally British Oceanographic Data Centre. Under here is a
Projects folder which contains a sub-folder for each project (i.e. BODC CD-
ROM product) for which the software is configured. Each project also has its
own folder containing a series of sub-folders.

Migrating Files onto the Hard Disk

The Underway Explorer will run considerably faster if its data files are
transferred from CD-ROM onto hard disk. Two types of file need to be moved
onto the hard disk: the underway data files and the bathymetric contour data
files used in the Map View.  On disk 1 the OMEX1 CD-ROM, these will be
found in the directories UNDERWAY and GEB_CON.

The first stage in the migration is to copy the files from the CD-ROM to the
hard disk using either File Manager or Windows Explorer. It doesn't matter
what the directories on the hard disk are called (they may be buried several
layers deep if desired), providing the FILE folder of the Registry entry for the
project is modified accordingly.

For the sake of argument, let's say that they have been placed in the
directories OMEX1\DATA\UNDERWAY and OMEX1\DATA\GEB respectively
on the C drive. The 'Bathymetry directory' and 'BM file directory' entries must
be modified so that they appear as follows:

Bathymetry directory "C:\OMEX1\DATA\GEB"
BM file directory "C:\OMEX1\DATA\UNDERWAY"



Installing Additional Projects

Whilst it is theoretically possible to use Regedit to build the necessary
Registry entries to add another project, this would be both long winded and
so error prone as to be suicidal. Consequently, BODC intend to make Setup
programmes available to install additional projects. Please get in touch if you
would like to extend the Underway and, for projects which include suitable
databases, Database Explorers to cover further BODC CD-ROM products.

Recovering from a 'White Out'

The Underway Explorer provides total user control over screen colours.
Changes to the screen colours are written to the Registry as soon as the
window to which they relate is closed. Total flexibility brings with it the
potential for disaster such as changing all the foreground colours and the
background colour to the same shade. Whilst, it is possible to recover from
this situation using the Underway Explorer user interface, clicking a blank
screen in the right place many times over can be a little frustrating to say the
least.

Many users will find it easier to use Regedit to save the day. A list of all the
colours used may be found in the Colours sub-folder for each project. These
may be set to either text names or hexadecimal numbers (not recommended).
The following are all valid text colour names:

clBlack clWhite clRed clBlue clAqua
clFuschia clGray clSilver clGreen
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