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Introduction

The BODC Database Explorer is a Windows95 application that provides
access to certain types of data held in the OMEX | JET database. It is
provided as a complementary tool to Microsoft Access to retrieve certain
types of data which require a 3-dimensional cross-tabulation capability
unsupported by Access.

The data types concerned are:

Water and air sample data (table BOTDATA)
Whole core data (table CORETOT)
Core profile data (table COREPROF)
Sediment trap data (table TRAPDATA)

Access forms are present in the database for each of these data types.
However, the lack of the necessary cross-tabulation support means that the
parameters measured are listed sequentially in columns and not in rows. The
Database Explorer provides the ability to retrieve the data in this more
conventional, and useful, format.

The Database Explorer provided with the OMEX | CD-ROM is the first release
of the software and as such it has limited capabilities. It is planned to further
develop the software to include additional data types and a graphical display
capability to release with BODC products planned for 1998. The enhanced
version of the software will be both compatible with the OMEX | database and
freely available to OMEX | CD-ROM users.



Using the Database Explorer

Launching the Database Explorer brings up a control window which appears
thus:
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Four pull-down menus, two of which are initially unavailable, plus five
universal control buttons are presented. Menu options may be invoked
through mouse clicks or by pressing Alt and the appropriate 'hot key'. Hot key
characters are underlined in the menus.

The Database Explorer is designed to operate on any database conforming
to the BODC Project Database structure. Consequently, the first operation
required is to open the desired JET database using the Open Project option
in the File pull-down menu. Clicking this gives a list of the BODC project data
sets currently installed on your computer. Simply choose the one you require.

Should the program not find the database file it requires, a standard Windows
Open dialog box is invoked asking you to specify the database file. In the
case of OMEX I, the required file is OMEX1V7.MDB which may be found in
the DBJET directory on Disk 1. This feature can be useful should you wish to
use a copy of the database copied to hard disk to improve performance.

Once the database has been opened, the Data and Options pull-down menus
become active. Please go to the section on the Data menu to find out what to
do next.



The File Menu

The File menu contains a number of control options which are listed below
together with their equivalent toolbar buttons:

Copy to Clipboard Copies the contents of the current
window to the Windows clipboard in @“
either tab, space or comma delimited
format. The delimiter is specified via the
clipboard format option in the Options menu.

Save As Saves the contents of the current
window to disk as either a plain ASCII E |
text file or comma separated ASCII. A

standard Windows dialog box allows the
destination path name and filename to be set

up.

Page Setup Allows the page margins of the printer
to be specified through a dialog box.

printer to be adjusted via a standard
Windows dialog.

Print Sends the contents of the current
window to the printer. The standard %
Windows dialog is opened up,

allowing the printer and number of copies to
be selected.

Printer Setup Allows the properties of the current —
I:;ll

In addition to the above, there are the standard Close (close current window),
Exit (quit program) options and the Open Project option discussed in the
Using the Database Explorer section.



The Data Menu

When a database is first opened, the Data Menu has only one active option,
Define, which offers the available data types via a sub-menu that currently
has the following options:

Bottle Water bottle and atmospheric sample data (BOTDATA)

Core Core profile data (COREPROF)

Whole Core Whole core and grab data (CORETOT)

Sed Trap Sediment trap data (TRAPDATA)
Choosing one of these options displays the appropriate Data Selection dialog
box. These differ in detail for each data type as different field subsets are
available.

The functional description of the Data Selection Dialog Boxes is subdivided
into the following sections:

Data Selection Dialog Description

Standard Category Descriptions

Advanced Category Descriptions

Specifying Output Header Columns

Selecting Data
After the OK button on the Data Selection Dialog has been pressed, the
program interrogates the database to find the data you have selected and
creates a working database on hard disk to speed up subsequent selections.
When this process has finished, choose Show from the Data Menu. This
invokes the parameter selection mechanism through a hierarchical series of
list boxes. Each of these follows the standard Windows criteria for list box
selection which are:

To choose a single item, or the first item of several, click on it.

To choose a range of items, click on the first item and then click on the last
item, pressing the Shift key at the same time.

To add items to a selected list, click on them, pressing the Ctrl key at the
same time.



To deselect an item from the list, click on it whilst pressing the Ctrl key at
the same time.

The first list offered allows you to select parameter categories which are
broad groupings of parameters. The general rule here is not to be too
conservative with your choices: you can always thin out the results later on.
However, if categories are obviously of no interest then exclude them as this
will reduce the length of the lists you have to plough through later on.

Once OK is pressed, you will be presented with a list of parameter groups.
These are generally readily identifiable parameter names, covering all
methods of measurement for that parameter. However, they can be more
encompassing. For example the parameter name CORG covers both DOC
and POC. The list box includes a floating help box that provides further
information on both the parameter name and the data originator. This is
useful, but can be a nuisance when making selections. Clicking the
Expanded View check box turns it off. Again, the standard Windows list
selection techniques are used.

Clicking OK brings up the full list of parameter and data originator
combinations available. Each record selected from this box will generate a
data and flag column in your output data grid. Once again, further information
on the parameter code and the data originator is offered via a floating help
box and this can again be disabled via the Expanded View check box. A
further control button on the dialog, labelled Fields, allows you a chance to
change the header columns selected for your output.

Pressing OK causes the data you have selected to be retrieved and
displayed as an output grid. This may be saved, printed or copied to other
applications using the options available through the File menu or the
command buttons in the control window.

The header columns included in the data grid may still be modified, even at
this late stage. Simply choose the Index Fields option from the Data pull-
down menu and a dialog box will be opened that allows header parameters to
be added or removed with ease.



Data Selection Dialog Description

The Bottle Data Selection dialog appears thus:

— Standard FRelds ——— - Advanced Fields
Search Show Search Show
[+ Position BODC event number
Date Originator's event identifier
Cruise Gear code
Bottle identifier
Depth Bottle type
X Cancel | Bottle problem indicator flag

It is essentially divided into two areas called 'Standard Categories' and
'‘Advanced Categories'. The Standard Categories are common to all data
types (although the subsidiary choices may vary) and form the main
independent variables upon which data selection is based. The Advanced
Categories are data type specific.

Each field has two buttons associated with it. The Search button controls
whether or not the field group is to be considered during data selection. The
Show button determines whether or not the field is to be included in the final
output grid. By default, no selection criteria are set (therefore all the data in
the database will be retrieved) and the position fields appropriate to a point
event (latitude and longitude) are included in the output listing.

The red cross in the centre of the buttons when depressed means that there
are additional user choices hidden below the button. These may be accessed
by clicking on the button to bring up a check list from which items may be
chosen.



Standard Category Descriptions

The Standard Fields are:

Position
Date
Cruise
Depth

Position Category

There are nine fields covered by the Position Category that may be revealed
by clicking on the Position Show button. These are:

Average latitude of deployment (+ve N)
Average longitude of deployment (+ve E)
Maximum deviation of latitude

Maximum deviation of longitude

Ship's latitude at start time

Ship's longitude at start time

Ship's latitude at end time

Ship's longitude at end time

Fixed station name

The first four fields are point event positions specified as a mean position and
maximum deviation from the mean position. The next four fields are the
position fields for traverse events. The final field is the site or fixed station
name (e.g. OMEX3) that is associated with some of the point events in the
database.

Point and traverse events are fundamental concepts in BODC project
database design. Further explanation of the concepts and implications for
data selection is included in the sections of this document on Specifying
Output Header Columns and Selecting Data.

Date Category

Two date category fields are common to all data types. These are:

Start Date
End Date



These refer to the start and end times of the data collection event. Note that
many events in the database are regarded as 'instantaneous' in which case
the end date will be set null. All events have a start date specified.

In the case of sediment trap data, there are two additional date fields
available. These are:

Start Date - SedTrap
End Date - SedTrap

These refer to the collection dates of individual trap samples whilst the event
start date and end date refer to trap deployment and recovery.

Cruise Category

This category contains a single field: the cruise mnemonic of the cruises
initiating the events.

Depth Category

For all data types, this includes the bathymetric depth: i.e. the water depth at
the position where the event occurred. Users should be aware that this wasn't
known for a significant number of events and in these cases the field was set
null.

For water bottle data, three additional depth category fields are available.
These are:

Bottle depth (m)
Minimum pressure sampled (db)
Maximum pressure sampled (db)

These fields pertain to the depth at which the sample was collected. All
samples have a bottle depth (air samples have negative 'depths') stored.
However, only samples collected using a CTD rosette will have the depth
stored in terms of pressure. Retrieving both pressure fields provides
information on the vertical range over which the sample was collected.

For sediment trap data, an additional depth field, the trap depth, is available.



Advanced Category Descriptions

The list of advanced categories available is dependant upon the data type
and they are described by data type in this document.

Bottle
Core
Whole Core

Sed Trap



Bottle Advanced Category Descriptions

BODC Event Number

This is the identifier, a simple integer number, assigned by BODC to each
event in the database.

Originator's Event Identifier

This is the identifier, a text field, by which the event was known to the data
originator or in the logs of the cruise on which it was collected. Sometimes,
no name was given to the event and in this case identifiers have been
assigned by BODC.

Gear Code

This is a mnemonic assigned to describe the type of oceanographic hardware
deployed during the event. The mnemonic translations are mostly intuitive. If
there is any problem, translations may be obtained using the Events form in
the Access database.

Bottle Identifier

This is the identifier, a simple integer number, assigned by BODC to each
bottle sample in the database.

Bottle Type

The Bottle Type field specifies how the sample was collected. For water
bottle data, this field identifies the type of water bottle used through the
following codes.

GFnn GoFlo

LNnn Lever-action Niskin (external spring)

NInn Niskin

NOnNn NIO bottle

NXnn NOEX bottle

TRNN Transparent (marine snow catcher)

PPnn Manually filled polypropylene bottle

KNnn Knudsen bottle

G300 Large volume (300 litre) radionuclide sampler

The 'nn' specifies the capacity of the water bottle in litres.



A number of other codes are used for other sampling methods:

BWS Benthic water sampler

SAP Stand-alone pump

PUMP Pumped sample (water or air pump)
BUCK Bucket on a rope

AIRB Air bottle

Bottle Problem Indicator Code

The Bottle Problem Indicator Code field is used to indicate known problems.
The coding convention used is:

Filter burst (SAP samples)

Contamination through leakage suspected
No sample obtained

Bottles fired in incorrect order

oOZrw

The 'O’ flag requires a little more explanation. This is used to flag stations
where there was obvious confusion from the sample data set about which
bottle was fired at which depth. These problems have been resolved during
data load, but the flag is included to remind users that there may be problems
with data from that station obtained outside the database.



Core Advanced Category Descriptions

BODC Event Number

This is the identifier, a simple integer number, assigned by BODC to each
event in the database.

Originator's Event Identifier

This is the identifier, a text field, by which the event was known to the data
originator or in the logs of the cruise on which it was collected. Sometimes,
no name was given to the event and in this case identifiers have been
assigned by BODC.

Gear Code

This is a mnemonic assigned to describe the type of oceanographic hardware
deployed during the event. The mnemonic translations are mostly intuitive. If
there is any problem, translations may be obtained using the Events form in
the Access database.

Core ldentifier

This is the identifier, a simple integer number, assigned by BODC to each
sub-core in the database.

Core Sample Identifier

This is the identifier, a simple integer number, assigned by BODC to each
core sample in the database. A core sample results when a core or sub-core
IS cut into sections or a point measurement is made along the length of a
core.

Core Flag

This flag is set to 'F' if the corer failed to return a sample or to 'S' if the corer
obtained stones and no sediment. It is blank for all cores that returned useful
data.



Distance From Core Top

This is the distance (in cm) from the top of the core to the mid-point of the
core sample. It therefore provides the independent variable for the core
profile.

Thickness of Segment

The segment thickness (in cm) is an expression of the resolution of the core
profile. If the profile was obtained by sectioning a core, then this is the
thickness of the slices obtained. For point measurements, such as electrode
profiles, it is set to zero.



Whole Core Advanced Category Descriptions

BODC Event Number

This is the identifier, a simple integer number, assigned by BODC to each
event in the database.

Originator's Event Identifier

This is the identifier, a text field, by which the event was known to the data
originator or in the logs of the cruise on which it was collected. Sometimes,
no name was given to the event and in this case identifiers have been
assigned by BODC.

Gear Code

This is a mnemonic assigned to describe the type of oceanographic hardware
deployed during the event. The mnemonic translations are mostly intuitive. If
there is any problem, translations may be obtained using the Events form in
the Access database.

Core ldentifier

This is the identifier, a simple integer number, assigned by BODC to each
sub-core in the database.

Core Flag

This flag is set to 'F' if the corer failed to return a sample or to 'S' if the corer
obtained stones and no sediment. It is blank for all cores that returned useful
data.



Sediment Trap Advanced Category Descriptions

BODC Event Number

This is the identifier, a simple integer number, assigned by BODC to each
event in the database.

Originator's Event Identifier

This is the identifier, a text field, by which the event was known to the data
originator or in the logs of the cruise on which it was collected. Sometimes,
no name was given to the event and in this case identifiers have been
assigned by BODC.

Gear Code

This is a mnemonic assigned to describe the type of oceanographic hardware
deployed during the event. The mnemonic translations are mostly intuitive. If
there is any problem, translations may be obtained using the Events form in
the Access database.

Sample Identifier

This is the identifier, a simple integer number, assigned by BODC to
individual trap samples.

Originator's Sample Identifier

This is the identifier given by the data originator to individual trap samples. It
is of particular importance for moored sediment traps with a sample carousel.

Sample Collection Time

This is the duration (in days) of trap sample collection.



Specifying Output Header Columns

By default, the only header fields that will be included in the data grid
generated by the Database Explorer will be latitude and longitude. It is down
to you, the user, to add whatever fields from the Standard and Advanced
Categories are required.

This is a simple, painless procedure. Clicking the appropriate Show Button
will either cause it to depress (indicating that a single field has been
included) or provide a list of the fields available within that category. Simply
check the fields you require from the list by clicking on them. When you have
completed this, click on any part of the window that isn't a button. The list will
disappear leaving the button, displaying the 'Red Cross' graphic, depressed.

If you don't like this way of doing things (or if you want to change your mind
about the fields you've selected later on) then there is another way. Choose
the Index Fields option from the Data pull-down menu. This opens up a dialog
box showing all the available fields with adjacent check boxes to allow them
to be selected and deselected with ease.



Selecting Data

The Search buttons in the Data Selection Dialog allow you to retrieve a
subset of the data held in the database on the basis of space, time or
operational parameters. At this stage, the program is only concerned about
which samples in the database are of interest to you. Choosing which
measurements you require on those samples comes later.

Using the Search buttons allows you to build up a filter query that is used to
select the samples of interest to you. Please note that this is progressive. In
other words, the sub-queries defined by each Search Button, or field within a
category, are combined using the AND operator. In other words, if you
specify that the bathymetric depth must be <1000 m and that the bottle depth
must be >1000 m then you're not going to find any data. At present, there is
no facility included in the program to allow the OR operator to be built into
queries.

In general, the specification of searches that return a predictable result is
straightforward. However, there is inevitably an exception which in this case
pertains to the inclusion of traverse events in position searches. In order to
understand what is meant by this, some explanation is required.

The BODC project data model is based on two fundamental types of event.
Point events are those which happened at what may be regarded as a fixed
point. Traverse events are those, such as instrument tows, which may not. In
the database, point events have their positions defined in the latitude and
longitude fields: traverse fields have their start and end positions defined in
the start and end latitude and longitude fields.

For reasons of practicality the definition of a point event is extended as far as
possible. If we have continuous navigation available during a traverse event
then a 'point position' may be determined with the variation fields set so they
define a box within which the event occurred. In these cases, both the point
and traverse event position fields are defined giving rise to what may be
termed schizophrenic events. However, there are cases where this was not
possible due to the lack of the necessary navigation data.

The result of this in practice is that it is possible for a position search on the
latitude and longitude fields to miss out traverse events that may contain data
of interest. It is therefore recommended that if you want to be sure that you
have found all of the data of interest then you should instigate three searches
on latitude and longitude, start latitude and longitude and end latitude and
longitude. Although this may seem a chore, it takes less time to do in practice
than it does to read and understand this description of the problem.



Pressing a Search Button opens up one of four types of dialog box that allow
the search criteria to be specified. These are:

Geographic Search Dialog
Date Search Dialog

List Box Search Dialogs
Numeric Value Dialogs

Text Entry Dialogs



Geographic Search Dialog

The Geographic Search Dialog allows the limits of a box search to be
specified in terms of latitude and longitude. The dialog box appears thus:
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By default, the box co-ordinates are specified in terms of degrees, minutes
and seconds. It is, however, possible to configure the dialog to accept any of
the following:

decimal degrees
degrees and decimal minutes
degrees, minutes and decimal seconds.

To change the configuration, simply click on the appropriate column heading
label.

The dialog field values may be specified using the increment and decrement
buttons provided or by simply placing the cursor in the appropriate box and
typing in the required value.

Don't forget to check that the hemispheric indicator boxes are set up as you
require, especially for longitude.

If the Position Search button doesn't depress when you quit the dialog box
then a syntax error has been detected and no search criteria have been set.



Date Search Dialog

The first stage in the specification of date/time criteria is to choose whether
you wish to specify a date before which the event occurred, after which the
event occurred, on which the event occurred, or within which the event
occurred. This is done by selecting the appropriate option from the list

offered.

The Date Search Dialog opens up thus to allow the date to be specified.
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To specify a date, first
specify the year. Next choose
the month by modifying the
month number or selecting
from the month name list box.
Finally, set the day by
modifying the numeric field or
clicking on the calendar.

If the date range option is
selected then the dialog box
presented is doubled up
allowing both the start and
end dates to be specified.



List Box Search Dialogs

The List Box Search Dialogs allow you to choose one or more items from an
available list. A typical example, for the Bottle Type field appears thus:

Cruise Search Dialog |

BG9309
BGY322A
BGY9322B
BGY9412
BGY47B
BGY9506
BGY9521
BGY9522
CDg3
CDg4
CDg5
CDg6
CD94
CD97?
DI216
Di217
HEINKEGS
JM1
JM10
JM11
JM2

JM3

JM4

JM5

JMb
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Choosing the items you require follows the
normal Windows conventions namely:

To choose a single item, or the first item
of several, click on it.

To choose a range of items, click on the
first item and then click on the last item,
pressing the Shift key at the same time.

To add items to a selected list, click on
them, pressing the Ctrl key at the same
time.

To deselect an item from the list, click on
it whilst pressing the Ctrl key at the same
time.



Numeric Value Dialogs

These are used to allow numeric values to be specified, generally the BODC
identifier fields or depths. The dialog appears thus:

BODC Event Number Dialog %] First click one of the check

boxes to determine whether
you want to choose values less

e than your specification, greater
" . than your specificat_ior_l, or
= values that fall within a

specified range. The desired
value or values are then

Clear | v OK | X Cancel entered into the appropriate

box by either typing or using

the increment and decrement
buttons.

Note that if you want to specify an exact match to a particular value then use
the range value with both boxes set equal. This will in fact happen
automatically if you set one box and then move the mouse cursor out of it.



Text Entry Dialogs

These are by far the simplest of the Selection Dialogs. Simply enter the
required text into the box supplied. Remember, that you must get the text
exactly right, including case and any punctuation.



The Options Menu

The Options Menu comes into play once your selection of data has been
retrieved into the data grid. The first option group controls the appearance of
the data grid. The options, shown with their equivalent toolbar buttons are:

Horizontal Lines:  Toggles the horizontal lines in the data grid on

=
and off. T
gco=i]
Vertical Lines: Toggles the vertical lines in the data grid on and
off. 11
Font: Allows the size, colour and font of the text in the
data grid to be specified through a standard F
Windows dialog box. |

The second group contains two options, Description and Clipboard format.
Checking the Description option opens an information window thus:
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The Clipboard format
option controls the field delimiter used when data are copied across to the
Windows clipboard. This may be set to be either a tab (more suited to
spreadsheets), space (more suited to word processors) or comma.

The third option group in the Options menu, ToolBar, is available at all stages
of the program. It simply toggles whether the toolbar and its buttons are
shown or hidden.
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